Redistribute Static Route Into Eigrp
EIGRP Redistribute Static Routes
- Command To Redistribute Static Route In Eigrp
- Redistribute Eigrp Into Ospf
- Nexus Redistribute Static Eigrp
- Redistribute Static Default Route Into Eigrp
- Cisco Nexus Redistribute Static Routes Into Eigrp
- Redistribute Static Default Route Into Eigrp
- Eigrp Redistribute Metric
With route Redistribute you can allow routes from one routing protocol to be advertised into another routing protocol. The routing protocol who accepts these redistribute routes are normally shows these routes as external routes in their routing table and these External-routes are normally have less metrics or preferable as compare to other routes like locally originated routes.
When you are within the inter-network, you are required a single routing protocol for managing your business. The concepts of Redistribute routes comes when you are required to connect different networks, branch-offices running with different routing protocol. With redistribute routes you can connect networks having different routing protocols.
EIGRP Redistribute Static Routes | Redistribute Static EIGRP
This article is about the redistribution of static routes and connected routes into EIGRP. For easy understanding I have simulated this lab in GNS3, you can configure the same for your practice in GNS3.
Lab Objectives
Redistribute static routes into EIGRP. Route Policy. Enter the name of the route policy to apply to redistributed routes. Click Add to save the. Configure R3 to redistribute EIGRP routes into RIP using a hop count of 3 then redistribute RIP routes into EIGRP using a T1 bandwidth and 20,000 microsecond delay. Verify on R1 and R5 that routes from the opposite autonomous system exist in their routing table. I would think configuring a static default route and advertising it into EIGRP with network 0.0.0.0 or redistributing static routes into EIGRP would do the trick. Either that, or configuring a classful network on the EIGRP ASBR to be the default network via ip default-network X.X.X.X. Hope this helps.
Following is the figure of Redistribute static route into EIGRP lab, where we have 3 routers RouteRouter1, RouteRouter2 and RouteRouter3. ROUTER1 and ROUTER3 are running with EIGRP and our objective is to redistribute the static routes from ROUTER2 into EIGRP so that these can be available at ROUTER3 as external routes.
ROUTER1’s Configurations
ROUTER1(config)#int f1/0
ROUTER1(config-if)#ip address 55.55.55.2 255.255.255.0
ROUTER1(config-if)#no shutdown
ROUTER1(config)#interface fastEthernet 0/0
ROUTER1(config-if)#ip address 192.10.10.1 255.255.255.0
ROUTER1(config)#router eigrp 10
Command To Redistribute Static Route In Eigrp
ROUTER1(config-router)#network 192.10.10.0 0.0.0.255
ROUTER1(config-router)#network 55.55.55.0 0.0.0.255
ROUTER1(config)#ip route 11.11.11.0 255.255.255.0 50.0.0.1
Redistribute Eigrp Into Ospf
ROUTER1(config)#ip route 22.22.22.0 255.255.255.0 50.0.0.1
ROUTER1(config)#ip route 33.33.33.0 255.255.255.0 50.0.0.1
ROUTER2’s Configurations
following configurations are required on router2.
ROUTER2(config)#interface f0/0
ROUTER2(config-if)#ip address 55.55.55.1 255.255.255.0
ROUTER2(config-if)#no shut
ROUTER2(config-if)#exit
ROUTER2(config)#interface loopback 1
ROUTER2(config-if)#ip address 11.11.11.1 255.255.255.0
ROUTER2(config-if)#interface loopback 2
ROUTER2(config-if)#ip address 22.22.22.1 255.255.255.0
ROUTER2(config-if)#interface loopback 3
ROUTER2(config-if)#ip address 33.33.33.1 255.255.255.0
For static route configurations you need to configure the destination network with next hop address with static route command as following:
ROUTER2(config)#ip route 192.10.10.0 255.255.255.0 50.0.0.2
ROUTER2(config)#ip route 66.66.66.0 255.255.255.0 50.0.0.2
ROUTER2(config)#ip route 77.77.77.0 255.255.255.0 50.0.0.2
ROUTER3’s Configurations
ROUTER3(config)#int f0/0
ROUTER3(config-if)#ip address 192.10.10.2 255.255.255.0
ROUTER3(config-if)#no shut
ROUTER3(config)#int loopback 1
ROUTER3(config-if)#ip address 66.66.66.1 255.255.255.0
ROUTER3(config-if)#exit English to malayalam translation software, free download for pc.
ROUTER3(config)#int loopback 2
ROUTER3(config-if)#ip address 77.77.77.1 255.255.255.0
ROUTER3(config-if)#exit
ROUTER3(config)#router eigrp 10
ROUTER3(config-router)#network 192.10.10.0 0.0.0.255
ROUTER3(config-router)#network 66.66.66.0 0.0.0.255
ROUTER3(config-router)#network 77.77.77.0 0.0.0.255
Static Routes redistribution into EIGRP Configurations on Router1
For eigrp Routes redistribution into static you required to create a route map with an access list to permits all routes which are going to redistribute into RIGRP. In our lab these routes are static routes we have permit these with ACL 7.
ROUTER1(config)#access-list 7 permit 11.11.11.1
ROUTER1(config)#access-list 7 permit 22.22.22.1
ROUTER1(config)#access-list 7 permit 33.33.33.1
ROUTER1(config)#route-map redistribute_static permit 10
ROUTER1(config-route-map)#match ip address 7
Redistribution Commands:
Now you are required to create a route map with the help of ACL7, I have created a route map “redistribute_static”
Nexus Redistribute Static Eigrp
ROUTER1(config)#router eigrp 10
Redistribute Static Default Route Into Eigrp
ROUTER1(config-route-map)# ROUTER1(config-router)#redistribute static route map redistribute_static
Cisco Nexus Redistribute Static Routes Into Eigrp
ROUTER1(config-route-map)# redistribute static metric 10000 1 255 1 1500 (not compulsory in case of static routes)
Redistribute Static Default Route Into Eigrp
Testing and verification of configurations:
Eigrp Redistribute Metric
For verification you can ping from Router1 to Router3’s loopback interfaces. After completing above configurations these static routes will be in ROUTER3’s routing table as the external routes. Loopback networks are configured at ROUTER1 and after complete configuration these routes will be appear in routing table of ROUTER3.